Compiling Acados for Microautobox 3


I’m using Acados with Matlab (2023b) with the goal to implement an MPC on a real time hardware, specifically the Microautobox3 (dSPACEDS1403 with ConfigurarionDesk 2023.2).

I have some question reguarding the propcess to crosscompilate and build the model.

  1. I was not able to run the “cmake -D CMAKE_TOOLCHAIN_FILE=…/cmake/Toolchain-dSPACEDS1403.cmake -G “Unix Makefiles” -S …/ -B ./” on Windows, but using WSL it worked. Is it the same?

  2. The libraries generated during the acados building are of a different format: .a instead of .lib. Is it correct?
    when I try to compile the simulink with ConfigurationDesk it reports an error:

Making library "test_dSpace.a" finished
Creating application image file ...
c:/program files/dspace rcphil 2023-b/compiler/linux_4.14_gcc_10.3/target/arm-linux-gnueabihf/bin/../lib/gcc/arm-linux-gnueabihf/10.3.0/../../../../arm-linux-gnueabihf/bin/ld.exe: C:\Users\samue\acados\buildDS1403\install\lib\libacados.a: error adding symbols: file format not recognized
collect2.exe: error: ld returned 1 exit status

Thanks for the support.


I found the way to compile the code for the dSpace Microautobox3.
The issue was related to a compilation flag: the gnu compiler of dSpace 2023 do not accept -J, instead it uses -I. Replacing it worked well.


1 Like