Changing solver options of QP Solver

Hello :wave:

I was trying out different solver options to generate a solver for an MPC application. I tried changing the maximum iteration option (ocp.solver_options.qp_solver_iter_max) to 200 iterations instead of the default 100 but the OCP still times out after 100 iterations. If anyone has any ideas as to why this happens, please do leave a message.

Hi, I think you should set the option ‘nlp_solver_max_iter’ to 200.

1 Like

Thank you. that works, I was confused between the NLP and QP solver options