Update OSQP to version 1.0 (beta)

Hi everyone, first of all thank you for the fantastic work on acados!
We are using acados ocqp_qp c interface and currently compare different solvers.

We recently discovered that OSQP supports CUDA in the current (beta) version. We would also like to try this out, as our target platform is an Nvidia Jetson.
Since acados currently only supports the stable version 0.6.3, I have tried to update osqp to the latest version. Since the osqp interface has changed a lot I have to change some things in the the respective acados wrapper.
I stumbled over osqp_workspace_calculate_size in ocp_qp_osqp.c. I understand what this function does in general, but I am not quite sure what is really happening.
In detail, I went through the function step by step (in the current version of acados and osqp) and tried to match the individual rows to the respective fields in OSQPWorkspace or underlying data structures. But this does not work.

Can someone with more experience maybe check on this?

1 Like

Hi Franek,

Thanks for the feature request.
This is something that we would like to have as well.
Some work already went into extending the OSQP interface in the last release v0.3.3.
The current OSQP acados interface however uses some OSQP internals that are deprecated in the new version 1.0.
The goal would be to overhaul the acados OSQP interface to not use such OSQP internals, such that it should be more robust to further OSQP updates.