Python generated c code not really work

Hi Frey
Thank for the nice tools.
I have used python interface to complete a task of a car trajectory track. The calculation results in python interface are as expected
Now I am trying to use the c interface to see how much the calculation speed has improved compared to python
Now the problem I have is
I called the generated c code under the python code
The program can run, but obviously acados does not calculate correctly
In the closed loop, the calculation result is always 0
Below is my code, can you help me to see where is the problem Thank you

This is problem is solved now
The trajectory should be an array, but in my case is a vector
I have already change it and the code can run now
Thanks again

May I ask how much improvement you achieved by porting everything to c code? This is due for me aswell, just curios how much it helped :slight_smile:

In my case it was just 0.x ms improve for every MPC iteration, not too much

1 Like

Alright, thank you for your insight! Have you tried Multithreading with OpenMP?