Cross-compiling issues

Hi all,

I took a step back from my latest post and decided to deploy my MPC on a MCU that can handle dynamic memory allocation. Therefore, I still use TI’s TMS320F280049C. However, I am having trouble cross-compiling acados. Could you give me a brief explanation on what I have to do in order to successfully cross-compile acados?
I already tried to adapt the Embedded Workflow that you are providing within the acados documentation. But I seem to overlook something since the libs that are generated within this process don’t work for me. I believe that the reason for my issue lies within the Cmake-Toolchain file. I’d be thankful if you could give me some advice on the most important steps that have to be covered when cross-compiling acados.
Thank you in advance!

Best regards,

Hi Leon,

as you found here: Embedded Workflow — acados documentation
The cross compilation workflow is only documented for some dSpace architectures.
However, the main points done in these Toolchain files need to be done when cross-compiling for any platform.
Such as setting the:

  • compiler
  • linker
  • BLASFEO target
  • HPIPM target
  • additional C Flags
  • remove definitions that are set automatically by running cmake from your host system

Maybe someone can help you more if you add some more specific information on what you tried, and where you are stuck.